Author Topic: PC wont boot with rx570  (Read 100 times)

Offline MarcJustCons

  • Semi-Newbie
  • *
  • Posts: 9
PC wont boot with rx570
« on: May 23, 2020, 08:03:42 PM »
Hey guys, i bought rx570 4gb (gigabyte). But after installing and plugging the 8pin (4+4pin). It wont boot up. But It does boot up without rx570. I also tried to turn on my pc without plugging the 8pin to check if rx570 is not working. But it does light up. Any help?


Specs:
AMD Fx6300
GIGABYTE GA78LMT S2 MOBO
GIGABYTE RX570
x2 8Gb HYPERX 1866MHZ
516watt PSU with (4+4 pin) and (6pin)

Online jeremypv

  • Member
  • **
  • Posts: 1053
    • jeremypv.net
Re: PC wont boot with rx570
« Reply #1 on: May 23, 2020, 09:16:07 PM »
does it really not boot? or no display lang? the board seems to have an integrated graphics card -- you may have to check on the bios settings (or the fine manual) on installing a discrete graphics card.

the manual is on the manufacturers website if you don't have it on hand
jeremypv

Offline MarcJustCons

  • Semi-Newbie
  • *
  • Posts: 9
Re: PC wont boot with rx570
« Reply #2 on: May 23, 2020, 10:26:26 PM »

I wont boot up po if the gpu is inserted and 4+4 pin is attached.

does it really not boot? or no display lang? the board seems to have an integrated graphics card -- you may have to check on the bios settings (or the fine manual) on installing a discrete graphics card.

the manual is on the manufacturers website if you don't have it on hand

Online splerdu

  • Veterans
  • Member
  • ***
  • Posts: 7843
Re: PC wont boot with rx570
« Reply #3 on: May 24, 2020, 12:01:01 AM »
Are you sure you're connecting the correct plug? I've never heard of 4+4pin PCIe power. That's usually an EPS connector for the motherboard. PCIe power is 6+2pin.





If you really did plug the 4+4 into the GPU then you're pretty lucky not to have fried it, as the PCIe +12V and GND pins are in reverse orientation from EPS12V.
fhtagn

Offline MarcJustCons

  • Semi-Newbie
  • *
  • Posts: 9
Re: PC wont boot with rx570
« Reply #4 on: May 24, 2020, 01:46:01 PM »
I was wrong. 4+4 isnt for gpu. It should be connected for the motherboard. In my case, it is for the atx 12v. I have 6pin my psu tho. I tried it and it works. But I knkw it is not getting enough power from power supply with 6pin. But I dont have 6+2 pin.


Are you sure you're connecting the correct plug? I've never heard of 4+4pin PCIe power. That's usually an EPS connector for the motherboard. PCIe power is 6+2pin.





If you really did plug the 4+4 into the GPU then you're pretty lucky not to have fried it, as the PCIe +12V and GND pins are in reverse orientation from EPS12V.

Online splerdu

  • Veterans
  • Member
  • ***
  • Posts: 7843
Re: PC wont boot with rx570
« Reply #5 on: May 24, 2020, 02:52:19 PM »
Check mo if the middle pin in the bottom row of your 6-pin has wire connected to it. If it has, then it's basically the same as 8-pin (3 +12V rails). You can short the extra pins not covered by the 6-pin to trick the GPU into thinking it's plugged into an 8-pin connector.

Either way you should have enough power. RX570 spec only calls for 120W total and 1x6pin connector, so Gigabyte putting in the 8-pin connector is overkill.
fhtagn