Author Topic: Laptop won't POST when HDD is plugged in  (Read 428 times)

Offline WallyWest

  • Member
  • **
  • Posts: 1859
Laptop won't POST when HDD is plugged in
« on: April 02, 2019, 09:22:07 PM »
Got a Compaq CQ40. Problem is it won't go into POST when a hard disk is connected. When I disconnect the HDD, it'll go into POST no problem. I've already tested the HDD and it works fine in a USB enclosure. I've also tried a known working HDD. Same problem. Basta nakakabit ang HDD, magf-freeze lang sa welcome screen ng "COMPAQ".

Any ideas on what else I can do to get this to work? I'm afraid the SATA controller may be the problem.

Worst case, I'm thinking of running it with Windows on a USB drive or taking out the DVD drive and replacing it with an HDD caddy as the DVD appears to be working fine.

Offline WallyWest

  • Member
  • **
  • Posts: 1859
Re: Laptop won't POST when HDD is plugged in
« Reply #1 on: May 02, 2019, 12:20:56 AM »
Tried the following to get the laptop working (or at least usable) :

1. Removed the DVD drive and replaced with an HDD caddy. I can install Windows or Linux on the HDD in the caddy but the BIOS wouldn't let the laptop boot from it. Already tried all possible options with the Boot Order menu. No good.

2. Made a Windows To Go installation to boot and run the OS from USB HDD. It works but is too slow to be usable.

3. Like 2 above but installed Linux on USB HDD. More usable than Windows but can't get the wifi to work even with the driver installed and the wifi drivers installed. Already Googled and tried several fixes. No good. It also seems that the more I "update" Linux, the longer it takes to get anything done. No good.

My last option is to combine solution 1 above with a USB key. The idea is to boot from the USB drive which will have grub or some boot manager  to "force" the laptop to run the OS that's on the secondary HDD.

Any ideas on how I can accomplish this with Windows in the HDD?

Offline WallyWest

  • Member
  • **
  • Posts: 1859
Re: Laptop won't POST when HDD is plugged in
« Reply #2 on: May 13, 2019, 03:20:58 PM »
Just for reference's sake, the 3rd solution worked.
Got Plop Boot Manager on a FAT USB flash drive to act as boot manager. Other than the necessity of plugging in a "key", it works like a normal laptop now.

Offline wheelee

  • Member
  • **
  • Posts: 3890
  • Nobody's tomorrow is guaranteed
Re: Laptop won't POST when HDD is plugged in
« Reply #3 on: May 14, 2019, 10:22:12 AM »
Good for you. Nice that you found a solution  -  a true PPCer ;)
what is love? baby don't hurt me, no more.